Using image for Fill on Theme Background

johnny.fowler2
32 Posts
johnny.fowler2 posted this 21 April 2019

I would like to have an Image Fill in my Theme Background that works for all Responsive views. I've tried 1920 x1080, 1920x1440, 1920x1280, 1920x980, etc.. It there an image size you can suggest? Can you give me information on optimum settings for images used as an Image Fill in Theme Background?

I've tried Covered, Contained, and Tiled with "fixed on scroll" selected and unselected. I cannot get it to work properly. I use a blank section at different places with comments to scroll over the image background, but yet to no avail.

I love the way it looks but cannot get to work on all Responsive views. Please advise!
Thanks,
Johnny

I would like to have an Image Fill in my Theme Background that works for all Responsive views. I've tried 1920 x1080, 1920x1440, 1920x1280, 1920x980, etc.. It there an image size you can suggest? Can you give me information on optimum settings for images used as an Image Fill in Theme Background? I've tried Covered, Contained, and Tiled with "fixed on scroll" selected and unselected. I cannot get it to work properly. I use a blank section at different places with comments to scroll over the image background, but yet to no avail. I love the way it looks but cannot get to work on all Responsive views. Please advise! Thanks, Johnny
Vote to pay developers attention to this features or issue.
18 Comments
Order By: Standard | Newest
johnny.fowler2
32 Posts
johnny.fowler2 posted this 21 April 2019

Is there a Nicepage Website Template that uses Image Fill in the Theme background I could use as an example?

Is there a Nicepage Website Template that uses Image Fill in the Theme background I could use as an example?
Support Team
Support Team posted this 23 April 2019

Hi JOHNNY,

It is difficult to suggest a specific size. There are a lot of different devices with different screen resolutions used for viewing websites. We cannot know the screen size on the side of the end visitor. The size of the background image depends on the screen size. The visible result could be different on different screens (desktop monitors, laptop screens, mobile devices...). It is difficult to control it as CSS does not provide many options for image size (cover, contain, repeat, etc). Therefore if the position of the specifiс parts of the image is important in your case, therefore, I suggest that you try to find an anoter way on how to achieve the result you want. Or pay attention to the position of the comments on the page and change this position according to the background image.

...................................................
Sincerely,
Olivia
Nicepage Support Team

Please subscribe to our YouTube channel: http://youtube.com/nicepage?sub_confirmation=1
Follow us on Facebook: http://facebook.com/nicepageapp

Hi JOHNNY, It is difficult to suggest a specific size. There are a lot of different devices with different screen resolutions used for viewing websites. We cannot know the screen size on the side of the end visitor. The size of the background image depends on the screen size. The visible result could be different on different screens (desktop monitors, laptop screens, mobile devices...). It is difficult to control it as CSS does not provide many options for image size (cover, contain, repeat, etc). Therefore if the position of the specifiс parts of the image is important in your case, therefore, I suggest that you try to find an anoter way on how to achieve the result you want. Or pay attention to the position of the comments on the page and change this position according to the background image. ................................................... Sincerely, Olivia Nicepage Support Team Please subscribe to our YouTube channel: http://youtube.com/nicepage?sub_confirmation=1 Follow us on Facebook: http://facebook.com/nicepageapp
johnny.fowler2
32 Posts
johnny.fowler2 posted this 23 April 2019

Thanks very much! I sort of figured that was the case. A background image must be made that fits the desired layout purpose. Thanks that makes sense.
Johnny

Thanks very much! I sort of figured that was the case. A background image must be made that fits the desired layout purpose. Thanks that makes sense. Johnny
Support Team
Support Team posted this 24 April 2019

Hi JOHNNY,

You are welcome. Feel free to contact us when you need our help again.

...................................................
Sincerely,
Hella
Nicepage Support Team

Please subscribe to our YouTube channel: http://youtube.com/nicepage?sub_confirmation=1
Follow us on Facebook: http://facebook.com/nicepageapp

Hi JOHNNY, You are welcome. Feel free to contact us when you need our help again. ................................................... Sincerely, Hella Nicepage Support Team Please subscribe to our YouTube channel: http://youtube.com/nicepage?sub_confirmation=1 Follow us on Facebook: http://facebook.com/nicepageapp
johnny.fowler2
32 Posts
johnny.fowler2 posted this 06 May 2019

I believe I've got background image working! The key is selecting the correct image for all situations and responsive sizing!
Thought I would show you how a "Background Image" on the Theme enhanced my site using Nicepage with Joomla!
Anchor of Grace website.

Johnny Fowler

I believe I've got background image working! The key is selecting the correct image for all situations and responsive sizing! Thought I would show you how a "Background Image" on the Theme enhanced my site using Nicepage with Joomla! [Anchor of Grace website][1]. Johnny Fowler [1]: https://anchorofgrace.org
Support Team
Support Team posted this 07 May 2019

Hi JOHNNY,

Nice to hear that you have worked it out. And thanks for sharing the result. Looks great! Feel free to contact us on any occasion.

...................................................
Sincerely,
Hella
Nicepage Support Team

Please subscribe to our YouTube channel: http://youtube.com/nicepage?sub_confirmation=1
Follow us on Facebook: http://facebook.com/nicepageapp

Hi JOHNNY, Nice to hear that you have worked it out. And thanks for sharing the result. Looks great! Feel free to contact us on any occasion. ................................................... Sincerely, Hella Nicepage Support Team Please subscribe to our YouTube channel: http://youtube.com/nicepage?sub_confirmation=1 Follow us on Facebook: http://facebook.com/nicepageapp
johnny.fowler2
32 Posts
johnny.fowler2 posted this 12 August 2019

For some reason the Joomla template Theme background image on the Joomla home page has recently changed to a white Theme background. This happened all of a sudden. I have the image on the desktop Nicepage theme. However, when I install the template to Joomla the background image is not there. When I edit with Nicepage online with Joomla the Theme background is white color. The Theme background image can only be loaded with Desktop Nicepage. I've reloaded the image and tried several template to fix but I cannot fix.

I had to change the sections using the background image on the home page to color backgrounds to fix for now. I guess Theme background image has been disabled in the Joomla Nicepage plugin for some reason.

Sad but true. Let me know if anyone else has this problem.

For some reason the Joomla template Theme background image on the Joomla home page has recently changed to a white Theme background. This happened all of a sudden. I have the image on the desktop Nicepage theme. However, when I install the template to Joomla the background image is not there. When I edit with Nicepage online with Joomla the Theme background is white color. The Theme background image can only be loaded with Desktop Nicepage. I've reloaded the image and tried several template to fix but I cannot fix. I had to change the sections using the background image on the home page to color backgrounds to fix for now. I guess Theme background image has been disabled in the Joomla Nicepage plugin for some reason. Sad but true. Let me know if anyone else has this problem.
Support Team
Support Team posted this 13 August 2019

Hi JOHNNY,

If you want us to investigate the problem, then please remove the background images that you have set for the blocks and also attach the project file. Then we may also need an access to the Joomla backend.

...................................................
Sincerely,
Hella
Nicepage Support Team

Please subscribe to our YouTube channel: http://youtube.com/nicepage?sub_confirmation=1
Follow us on Facebook: http://facebook.com/nicepageapp

Hi JOHNNY, If you want us to investigate the problem, then please remove the background images that you have set for the blocks and also attach the project file. Then we may also need an access to the Joomla backend. ................................................... Sincerely, Hella Nicepage Support Team Please subscribe to our YouTube channel: http://youtube.com/nicepage?sub_confirmation=1 Follow us on Facebook: http://facebook.com/nicepageapp
johnny.fowler2
32 Posts
johnny.fowler2 posted this 13 August 2019

Hella,
I made a new template and removed the Background on Sections, 2, 4, & 6. The Theme background image shows up on Quick Preview and Firefox through Sections 2,4, & 6. However when I upload and install aog_template144.zip and upload Content with Nicepage Import Data, then Sections 2,4, & 6 are with White (as set by the new Theme background of "White" when checked with Joomla Nicepage plugin for Home article, "Anchor of Grace - Home (105)".
Attached:
Template "aog_template144.zip
Project "aog_project144.zip
Template and Project file are too large to attach.
Where do I email files with ID and password for Joomla Administrator backend access ?

Johnny

Hella, I made a new template and removed the Background on Sections, 2, 4, & 6. The Theme background image shows up on Quick Preview and Firefox through Sections 2,4, & 6. However when I upload and install aog_template144.zip and upload Content with Nicepage Import Data, then Sections 2,4, & 6 are with White (as set by the new Theme background of "White" when checked with Joomla Nicepage plugin for Home article, "Anchor of Grace - Home (105)". Attached: Template "aog_template144.zip Project "aog_project144.zip Template and Project file are too large to attach. Where do I email files with ID and password for Joomla Administrator backend access ? Johnny
johnny.fowler2
32 Posts
johnny.fowler2 posted this 13 August 2019

Note: The forced White Theme background is not appropriate for the site. So I clicked on Sections 2,4, & 6 "Fill" and made the blocks a color that is not objectionable. After the Template.zip file is installed the Theme background image is not selectable and the Fill color is forced to White..

Sent email to Oleg!

Note: The forced White Theme background is not appropriate for the site. So I clicked on Sections 2,4, & 6 "Fill" and made the blocks a color that is not objectionable. After the Template.zip file is installed the Theme background image is not selectable and the Fill color is forced to White.. Sent email to Oleg!
johnny.fowler2
32 Posts
johnny.fowler2 posted this 14 August 2019

I was starting to have all sorts of problems.
Theme Background image not showing.
Getting error in Firefox that Nicepage is not supported use Chrome.
Images missing from several Nicepage articles.
I downloaded from Nicepage Download the joomla_nicepage_plugin-1.13.4.zip and installed.

All my problems went away. I have three Nicepage websites that I maintain and I've noticed that Nicepage update for Extension updates has not appeared as often. But I still get updates for the Desktop Nicepage App.
Sorry about all the problems. It works great again. My Theme Background image is up and all my images have returned.
Johnny

I was starting to have all sorts of problems. Theme Background image not showing. Getting error in Firefox that Nicepage is not supported use Chrome. Images missing from several Nicepage articles. I downloaded from Nicepage Download the joomla_nicepage_plugin-1.13.4.zip and installed. All my problems went away. I have three Nicepage websites that I maintain and I've noticed that Nicepage update for Extension updates has not appeared as often. But I still get updates for the Desktop Nicepage App. Sorry about all the problems. It works great again. My Theme Background image is up and all my images have returned. Johnny
johnny.fowler2
32 Posts
johnny.fowler2 posted this 14 August 2019

I'm glad I noticed this. I checked one of my other Nicepage websites and the Nicepage Extension for Joomla was only version v1.10.7 instead of v1.13.4

I'll have to carefully check all three sites for the Nicepage Extension update version, everytime I get an update the Desktop Nicepage app.

Thanks much!
Johnny

I'm glad I noticed this. I checked one of my other Nicepage websites and the Nicepage Extension for Joomla was only version v1.10.7 instead of v1.13.4 I'll have to carefully check all three sites for the Nicepage Extension update version, everytime I get an update the Desktop Nicepage app. Thanks much! Johnny
Support Team
Support Team posted this 15 August 2019

Hi JOHNNY,

Thanks for the reply. Nice to hear that the latest update solved the issues. Please feel free to contact us with any other questions you may have.

...................................................
Sincerely,
Hella
Nicepage Support Team

Please subscribe to our YouTube channel: http://youtube.com/nicepage?sub_confirmation=1
Follow us on Facebook: http://facebook.com/nicepageapp

Hi JOHNNY, Thanks for the reply. Nice to hear that the latest update solved the issues. Please feel free to contact us with any other questions you may have. ................................................... Sincerely, Hella Nicepage Support Team Please subscribe to our YouTube channel: http://youtube.com/nicepage?sub_confirmation=1 Follow us on Facebook: http://facebook.com/nicepageapp
johnny.fowler2
32 Posts
johnny.fowler2 posted this 15 August 2019

I always check the Joomla Control Panel Extensions and it read "All Extensions up to date." on another of my websites with the old version v.10.7!
Thanks
Johnny

I always check the Joomla Control Panel Extensions and it read "All Extensions up to date." on another of my websites with the old version v.10.7! Thanks Johnny
johnny.fowler2
32 Posts
johnny.fowler2 posted this 15 August 2019

In fact I checked my third website and it displayed "All Extensions up to date. and it had v1.11. something. I had to manually update all three websites.

In fact I checked my third website and it displayed "All Extensions up to date. and it had v1.11. something. I had to manually update all three websites.
johnny.fowler2
32 Posts
johnny.fowler2 posted this 15 August 2019

All of my websites are on Hostgator ISP

All of my websites are on Hostgator ISP
johnny.fowler2
32 Posts
johnny.fowler2 posted this 15 August 2019

Each website has it's own IP on different servers.

Each website has it's own IP on different servers.
Support Team
Support Team posted this 15 August 2019

Hi JOHNNY,

We'll continue to communicate in another case about this problem.

...................................................
Sincerely,
Hella
Nicepage Support Team

Please subscribe to our YouTube channel: http://youtube.com/nicepage?sub_confirmation=1
Follow us on Facebook: http://facebook.com/nicepageapp

Hi JOHNNY, We'll continue to communicate in another case about this problem. ................................................... Sincerely, Hella Nicepage Support Team Please subscribe to our YouTube channel: http://youtube.com/nicepage?sub_confirmation=1 Follow us on Facebook: http://facebook.com/nicepageapp
You must log in or register to leave comments